Use Case:
Attempting to sign into the Acronis Management Console.
Symptoms:
Upon attempted login, you get an error that the user is not allowed access:
Root Cause:
This may happen if the AMS was installed prior to the machine being domain joined as it will remove the local users/groups.
Solution:
Windows:
Uninstall the agent leaving the config/logs in place and re-install. During the installation it will prompt for domain credentials if needed.
Linux:
By default in Linux, the only user able to log into the management console is the root user. To add other accounts, please follow the steps below.
- Log into the management console as root user
- Click Settings > Accounts.
The software displays the list of the management server administrators and the tree of units (if any).
- Select Organization or select the unit where you want to add an administrator.
- Click Add account.
- Search for the user name or the user group name.
- Click "+" next to the name of the user or group.
- Select the role for the account.
- Repeat steps 4-6 for all users or groups that you want to add.
- When finished, click Done.
- Add the user names to Pluggable Authentication Module (PAM) configuration for Acronis modules as described below.
On the machine running the management server, as the root user, open the file /etc/security/acronisagent.conf with a text editor.
In this file, type the user names that you added as the management server administrators, one per line.
Save and close the file.