Applies to:
- Acronis Cyber Backup 12.5
- Acronis SCS Cyber Backup 12.5 Hardened Edition
Use Case:
Installing Acronis Cyber Backup 12.5 or SCS Hardened Edition in a standalone environment with no network connection.
Symptoms:
Installation log generates the following error during the installation process:
Registration Failed Failed to register the following components on the management server: Backup Agent: Failed to connect to the management server For details, view the installation log |
Root Cause:
Backup 12.5/Hardened Edition requires a network adapter with a usable IP address in order to successfully register the Agent and Management Server components during installation, without this the process will fail.
Air-gapped systems by design lack any sort of network connectivity as they are machines that have been isolated from any sort of external connection. As such, any network adapter on the machine will default to a "Media Disconnected" state as seen below. This state overrides any preset designation the adapter may have such as a static IP address.
While in this state, if you attempt to install Backup 12.5 it will fail as it is unable to register the Agent with the Management Server due to the lack of an IP address.
Solution:
Backup 12.5/Hardened Edition does not officially support this type of environment. The nature of its design to function as a centralized backup product, not as a standalone piece of software.
Workaround:
There are two possible solutions:
- Utilize a "dummy" switch to physically connect to the machine in question in order to trick Windows into believing there is network activity on the adapter and thus display whatever IP address is assigned to the adapter.
- Once this is done the installation can be completed.
- Afterwards the switch can be removed and the Management Console can be accessed and used as normal (Be advised that accessing the Console make take longer than usual as the system has to actually time out first since it no longer has the IP)
- Backup functionality and license assignment has been verified in this configuration
- Any additional functionality that requires external connectivity is NOT supported in this configuration
- Additionally the Edge and Firefox browsers are NOT supported under this configuration
- Internet Explorer is verified in this configuration.
- Install the Microsoft Loopback Adapter included in Windows installations prior to running the Acronis Backup Installer.
- From Device Manager, Select Action > Add legacy hardware. This will launch the Add New Hardware Wizard.
- In the Add Hardware Wizard select "Install the hardware that I manually select from a list(Advanced)
- In the list select "Network Adapters" then Manufacturer: "Microsoft" and in the Model list: "Microsoft KM-TEST Loopback Adapter"
- After installation proceed with running the Acronis Backup Installation or perform a manual agent registration via command line to add the machine to the management server.
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